Export Bug / Issue

pixel editor for iPhone.
maersk
New face
Posts: 2
Joined: Sun Apr 15, 2012 4:50 pm

Export Bug / Issue

Postby maersk » Sun Apr 15, 2012 4:58 pm

Hello, I downloaded pixation and was pleasantly surprised by how useful it is!

But I ran into one really really big deal breaking issue after spending a couple of hours on a sprite...

No matter how many times I save the work for some odd reason when I send the sprite to myself via email - I never get the sprite I've saved. I've done it 8times now and each time the sprite that is emailed to me is the first little scribble that I made as soon as I opened pixation for the first time and not the sprite I'm trying to send to myself.

PLEASE help she'd some light on how I might be able to salvage my work

thanks!

User avatar
LFA
L.F.A. TEAM
Posts: 16
Joined: Sat May 14, 2011 12:02 pm

Re: Export Bug / Issue

Postby LFA » Mon Apr 16, 2012 1:47 am

Hi there,

can you tell me what kind of device and ios version you are running? this will help me try to replicate.

Also, are you saying that the save/open functionality is working, but that it never sends the correct file?

Are the names of the original scribble and your good sprite similar?

What if you save your good sprite with a new name, and send that - does that work?

thanks for posting about your issue btw! :)
lemme know and maybe i can figure out what it is


PS
if DONT reinstall pixation or you could lose your work.
we'll figure this out.

maersk
New face
Posts: 2
Joined: Sun Apr 15, 2012 4:50 pm

Re: Export Bug / Issue

Postby maersk » Mon Apr 16, 2012 4:17 am

Hi There and thanks for the quick reply,
I'm running pixation on iOS 5.1 on a first gen iPad (the larger screen is much nicer to do pixel work on (why on earth isn't pixation a universal app?! - even iPad only would probably help your sales for this great app)

Yes the save / open functionality is working - just not sending the correct file.

No - the names of the 2 files were not similar.

I did try re saving the sprite a couple of different times with new names with no luck.

And one more *really* odd thing happened - if I saved to photo library from the email that was sent - the file would appear in the library with some random photo as the background and not the transparent one it was made with?!
But you could only see this ghost photo in the photo library thumbnail and it would go back to transparent when tapped for the full view...

In the end this whole issue was resolved by force quitting pixation and restarting it

But it was very strand and a little unsettling - that random background photo wasn't even mine!?

Another bit of bad behavior I noticed is that the brush width will sometimes reduce on its own...

And while were talking - I'm just curious why it saves as .gif and not .png?

Thanks:)

User avatar
LFA
L.F.A. TEAM
Posts: 16
Joined: Sat May 14, 2011 12:02 pm

Re: Export Bug / Issue

Postby LFA » Mon Apr 16, 2012 10:50 am

I really appreciate your feedback - and some good questions!

And while were talking - I'm just curious why it saves as .gif and not .png?

The reason i use gif and not png is because png animation is not supported universally like gif anim. I wanted Pixation to be extremely easy for users to pass their animations around without hardly understanding anything about how they work. It would have been nice to use png instead and maybe even lose the need to have them indexed but it would have made the images larger files and also probably a large % of casual users dont really know what to do with a png file... i even considered having it do png automatically if your image is only 1 frame but i decided against it just to keep things simple. Part of what i wanted with pixation was to be very careful about where i added complexity - which I think is why it feels very useful despite its 'simplicity'.

And one more *really* odd thing happened - if I saved to photo library from the email that was sent - the file would appear in the library with some random photo as the background and not the transparent one it was made with?!
But you could only see this ghost photo in the photo library thumbnail and it would go back to transparent when tapped for the full view...

As far as the background on the image in the bg in photo library... thats very odd but it seems a bug in their photo viewer since the gif seems to have stored the transparent pixels properly based on your description of the issue.

Another bit of bad behavior I noticed is that the brush width will sometimes reduce on its own...

Remember that the brush size is determined by your zoom level.
OR do you mean something else is happening?

(why on earth isn't pixation a universal app?! - even iPad only would probably help your sales for this great app)

Well, Pixation hasn't done too well overall, I think mostly because i hardly did any marketing.. since i made it i have learned a bit about marketing. I have been thinking about making it be able to conform properly to the iPad screen and trying a re-release. Thing is it would be a bit of work and I'm not sure it would pay off... it would be out of love for the app if it did it :) -which i still might actually do.

I am also going to look and see if i can replicate the scenario you encountered.
Can you remember the steps you took that made it happen? For example did you start pixation and let the device sleep several times or something like that? Or did you shut down pixation start it again, made a new image and try to send that?

Thanks again for your really helpful feedback.


Return to “Pixation”

Who is online

Users browsing this forum: No registered users and 1 guest

cron