Input messed up on Linux

New face
Posts: 2
Joined: Tue Jul 14, 2015 1:06 pm

Input messed up on Linux

Postby groenings » Tue Jul 14, 2015 1:16 pm

Hey there,

I hope that this is the right place to file my problem and I've tried hard to eliminate any fault on my side. However, there is of course still the chance that I messed up something on my computer.

I've played the game a few times, some weeks ago, and just tried to play it again. I'm playing on Debian-Linux, and after installing the updates today, I'm not really able to play the game any more: As soon as I enter a map (any map, including the tutorial) and start to move in one direction (meaning I press either W, A, S or D), my bunny does not stop moving. I can still influence his movements, pick up items, talk to other people, but I can't stop my bunny.

I'm not really sure what else to say: I have not connected any joysticks, I can type and play other games.
What might also be interesting: I can press the ESC-button once and the menu pops up. I can play around with the menu, although the 'Controls' Menu seems messed up. (Sometimes, I can edit the keys, sometimes I can't)
Once I close the menu and return to the game, my bunny starts moving again and I cannot open the menu any more. I have to kill the game and restart.
I've restarted the game several times, I've deleted and reinstalled the game, I have rebooted my computer.

If anyone has an idea what the source of my problem might be, I would be very thankful!


User avatar
Posts: 386
Joined: Thu Jun 02, 2005 11:16 pm

Re: Input messed up on Linux

Postby dez » Tue Jul 14, 2015 5:45 pm

Hi groenings,

yes this is a known issue, I am very sorry about it.
Basically Unity introduced this bug on the Engine side in the last build (so i didn't notice it come in). They have the fix out already and I will be pushing it out to you in the next few days with my own improvements. :)

Really sorry for the inconvenience. Please continue to report stuff like this because I dont always know about it.

Would you like to help test that it is gone in the latest ver? If so please ping me on Steam or pm :)

New face
Posts: 2
Joined: Tue Jul 14, 2015 1:06 pm

Re: Input messed up on Linux

Postby groenings » Thu Jul 16, 2015 1:15 pm

Hey dez,

Thank you for your reply! Good to know that you're already working on it.
Sure, I'd be happy to help. I'll send you a pm right away :)

Return to “bug reports”

Who is online

Users browsing this forum: No registered users and 1 guest